As of version 6.26, it is necessary to use AdoptOpenJDK 8 software instead of the regular OpenJDK 8, as OpenJDK 8 is not supported since April 2021.


AdoptOpenJDK installation guide: https://abi.ria.ee/xtee/en/turvaserveri-haldus/turvaserveri-adoptopenjdk-paigaldamine

X-Road software needs to be upgraded to 6.26.0 version before changing Java 8 package to Adopt OpenJDK: https://abi.ria.ee/xtee/en/turvaserveri-haldus/turvaserveri-uuendamine