Dear X-tee members!

We officially support only the two latest versions released: 6.23.0 and 6.22.1. These will also receive hotfixes by NIIS, if that should be necessary.

Please upgrade your Security Servers to version 6.23.0. To upgrade a Security Server, please make sure that it is using the correct repository.

Please check and if needed, modify the APT source list: /etc/apt/sources.list.d/xroad.list:

Then, you can upgrade the Security Server with the following commands:

  • Update available packages: sudo apt-get update
  • We recommend first upgrading the PostgreSQL: sudo apt-get install postgresql-9.3 --only-upgrade (PostgreSQL v9.4 users should use "postgresql-9.4“ in the command)
  • Install the latest X-Road package: sudo apt-get install xroad-securityserver-ee
  • We also recommend updating the rest of the server software: sudo apt-get dist-upgrade

NB! Since X-Road version 6.21.2, all later updates are available only to Ubuntu 18.04 users. The latest X-Road version is 6.23.0. If you are running a much older version or you have any questions, please let us know by writing to: help@ria.ee

Please update your Security Servers in 4 weeks time to provide a more secure data exchange environment for all. You can also catch up on the latest changes and fixes by reading the release notes.