Hea X-tee liige!

  

Tuletame meelde, et ametlikult on X-teel toetatud ainult viimased kaks versiooni: 6.23.0 ja  6.22.1. Need saavad ka NIIS-i poolt kiirparandusi, kui selleks peaks vajadus tekkima.

  

 Palun uuendage enda turvaserver(id) versioonile 6.23.0. Palume seda teha 4 nädala jooksul, augusti teiseks nädalaks.

  

Olulised punktid enne turvaserveri uuendamist:

  • Viimane versioon on 6.23.0
  • Ubuntu 18 kasutajad saavad uuendama turvaserveri tarkvara käsuga: sudo apt install xroad-securityserver-ee
  • Ubuntu 14 kasutajad peavad uuendama turvaserverit koos üleminekuga Ubuntu 18.04 peale. Juhend:Upgrade Using Configuration Backup.pdf 
  • Ubuntu 14 pealt 18-le üleminejad peavad KINDLASTI enne uuendama turvaserveri vähemalt 6.21.1 peale. Vajadusel uuendama ka X-Road tarkvarapakkide allikat. 
  • Ubuntu 14 tugi lõppes aprillis 2019 ja viimane X-Road tarkvara versioon sellele oli 6.21.2     

Vanemate, kui 6.21.1 X-Road tarkvara kasutajad peavad esmalt uuendama tarkvarapakkide allikat ja võtit:

Seejärel saate turvaserveri uuendada järgmiste käskudega:

  • Uuenda saadaolevaid pakke: sudo apt-get update
  • Ubuntu 14 korral soovitame uuendada PostgreSQL: sudo apt-get install postgresql-9.3 --only-upgrade (PostgreSQL v9.4 kasutajad kasutavad „postgresql-9.4“ käsu lõpus) 
  • Paigalda uuem X-Road tarkvara: sudo apt-get install xroad-securityserver-ee   
  • Soovitav on uuendada ka ülejäänud serveri tarkvara: sudo apt-get dist-upgrade     

Kui Teil tekkis mõni küsimus või soovite rohkem abi turvaserveri tarkvara uuendamisega, siis kirjutage meile aadressile:help@ria.ee

  

Uutes versioonides lisatud funktsionaalsuste ja paranduste kohta saate ülevaatemuudatuste nimekirjast.